flutter_firestore_visual_query 0.1.0 icon indicating copy to clipboard operation
flutter_firestore_visual_query: ^0.1.0 copied to clipboard

A visual way to query your firestore database for testing using Flutter

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 22 API elements (22.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:flutter_firestore_visual_query/flutter_firestore_visual_query.dart that imports:
  • package:flutter_firestore_visual_query/src/firestore_query_widget.dart that imports:
  • package:flutter_firestore_visual_query/src/bloc/query_state.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:flutter_firestore_visual_query/flutter_firestore_visual_query.dart that imports:
  • package:flutter_firestore_visual_query/src/firestore_query_widget.dart that imports:
  • package:flutter_firestore_visual_query/src/bloc/query_state.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:flutter_firestore_visual_query/flutter_firestore_visual_query.dart that imports:
  • package:flutter_firestore_visual_query/src/firestore_query_widget.dart that imports:
  • package:flutter_firestore_visual_query/src/bloc/query_state.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:flutter_firestore_visual_query/flutter_firestore_visual_query.dart that imports:
  • package:flutter_firestore_visual_query/src/firestore_query_widget.dart that imports:
  • package:flutter_firestore_visual_query/src/bloc/query_state.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: The import of 'package:flutter/cupertino.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/firestore_query_widget.dart:3:8

  ╷
3 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firestore_query_widget.dart

INFO: The import of 'package:flutter/rendering.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/cupertino.dart'.

lib/src/firestore_query_widget.dart:5:8

  ╷
5 │ import 'package:flutter/rendering.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firestore_query_widget.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.16.10.16.18.1.0
cloud_firestore^0.12.9+50.12.114.1.0
flutterflutter0.0.00.0.0
flutter_bloc^0.22.10.22.18.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
firebase-7.3.39.0.3
firebase_core-0.4.52.3.0
firebase_core_platform_interface-1.0.44.5.2
firebase_core_web-0.1.1+22.0.1
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.5
http_parser-3.1.44.0.2
js-0.6.40.6.5
matcher-0.12.130.12.13
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.1.3
provider-3.2.06.0.4
quiver-2.1.53.1.0
rxdart-0.22.60.27.7
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint ^0.16.1 on bloc does not support the stable version 1.0.0.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint ^0.12.9+5 on cloud_firestore does not support the stable version 0.13.0+1.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.2.2 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.20, Flutter 3.3.7, Dart 2.18.4.

0
likes
90
pub points
0%
popularity

Publisher

verified publisher iconthinkdigital.software

A visual way to query your firestore database for testing using Flutter

Homepage

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

bloc, cloud_firestore, flutter, flutter_bloc

More

Packages that depend on flutter_firestore_visual_query