flutter_firestore_visual_query 0.0.2

flutter_firestore_visual_query #

A visual way to query your firestore database for testing. This package provides a simple UI for querying Firebase that you can just plug into your existing code. This is useful for testing queries without having to manually create functions and run the code. It can be plugged in anyway, but a Drawer EndDrawer, or full page widget is the best option. I'm looking for suggestings, bug reports, feature requests and new UIs, pull requests and more, so feel free to contribute!

Roadmap #

[ ] Support writing map objects to firebase.

[ ] Multiple ways of rendering widgets. Ie. Pagination for maps.

[ ] Support for all datatypes in widgets that make sense.

[ ] New UI.

[0.0.1] - 5/11/19

  • Initial Release.

[0.0.2] - 5/12/19

  • Bug fixes. Updated README. Added LICENSE and CHANGELOG

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_firestore_visual_query: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_firestore_visual_query/flutter_firestore_visual_query.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
44
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (bloc, cloud_firestore, flutter_bloc).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_firestore_visual_query.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
bloc ^0.13.0 0.13.0 0.14.4
cloud_firestore ^0.11.0+1 0.11.0+2 0.12.7
flutter 0.0.0
flutter_bloc ^0.13.0 0.13.0 0.19.1
Transitive dependencies
collection 1.14.11
firebase_core 0.4.0+6
meta 1.1.6 1.1.7
rxdart 0.22.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin