flutter_easy_utils 1.0.5
flutter_easy_utils: ^1.0.5 copied to clipboard

A Flutter package to handle dialogs , snakbars , loading , shareprefranse , api requests and more.

8
likes
90/ 130
pub points
11%
popularity

We analyzed this package 20 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 93 API elements (22.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_easy_utils/flutter_easy_utils.dart that imports:
  • package:flutter_easy_utils/src/EasyApp.dart that imports:
  • package:flutter_easy_utils/src/providers/ThemeProvider.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/api/APIError.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/api/APIMixin.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
admob_flutter^1.0.11.0.11.0.1
cached_network_image^3.0.03.2.03.2.0
connectivity^3.0.63.0.63.0.6
dio^4.0.04.0.44.0.4
ez_localization^1.0.0+21.0.0+21.0.0+2
flutterflutter0.0.00.0.0
flutter_easyloading^3.0.03.0.33.0.3
flutter_icons^1.1.01.1.01.1.0
flutter_localizationsflutter0.0.00.0.0
flutter_spinkit^5.0.05.1.05.1.0
in_app_review^2.0.12.0.32.0.3
nested^1.0.01.0.01.0.0
new_version^0.2.20.2.30.2.3
package_info_plus^1.0.51.3.01.3.0
page_transition^2.0.22.0.42.0.4
permission_handler^8.1.4+28.3.08.3.0
provider^6.0.06.0.16.0.1
rflutter_alert^2.0.22.0.42.0.4
share^2.0.42.0.42.0.4
shared_preferences^2.0.52.0.92.0.9
url_launcher^6.0.96.0.176.0.17
webview_flutter^2.0.42.3.12.3.1
whatsapp_unilink^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
crypto-3.0.13.0.1
csslib-0.17.10.17.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
in_app_review_platform_interface-2.0.22.0.2
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.7.01.7.0
mime-1.0.11.0.1
octo_image-1.0.11.0.1
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.7.03.7.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
rxdart-0.27.30.27.3
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
webview_flutter_android-2.4.02.4.0
webview_flutter_platform_interface-1.8.01.8.0
webview_flutter_wkwebview-2.5.02.5.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.