flutter_dynamic_forms_components 0.11.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

flutter_dynamic_forms_components #

pub package

A flutter project containing default set of components for the flutter dynamic forms library.

Most of the components are generated using dynamic_forms_generator.

Note There is an issue where example project may not work in the IDE after running flutter packages pub run build_runner build. You can work around it by deleting .dart_tool folder.

0.11.0 #

  • Made the text widget obsolete. Added textField widget instead.
  • Using new parser methods from dynamic_forms 0.11.0.

0.10.1 #

Fixed analyzer issues.

0.10.0 #

  • Updated dependency for flutter dynamic forms.
  • Increased minimum dart SDK to 2.6.0.

0.9.0 #

  • Updated dependency for flutter dynamic forms and generator.
  • Components are now using new format for the Model and Parser classes.
  • Removed address component.
  • Date and DateRange components are now generated from YAML files.

0.8.0 #

Updated dependency for flutter dynamic forms and generator.

0.7.3 #

Added slider component.

0.7.2 #

Added date range component.

0.7.1 #

Added date component.

0.7.0 #

Updated dependency for flutter dynamic forms and generator.

0.6.0 #

  • Added component generator.
  • Added missing parsers.

0.5.0 #

Added multi select chip group component.

0.4.0 #

  • Added base class for select components.
  • Added single select chip group component.

0.3.0 #

Removed screaming caps convention.

0.2.0 #

Removed dependency on xml from parsers.

0.1.0 #

Initial Version of the library.

example/README.md

flutter_dynamic_forms example #

Example flutter app using default components.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_dynamic_forms_components: ^0.11.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_dynamic_forms_components/flutter_dynamic_forms_components.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Jan 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-0.89 points)

560 out of 562 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/default_parsers.dart. (-1 points)

Analysis of lib/src/default_parsers.dart reported 2 hints:

line 16 col 5: 'TextParser' is deprecated and shouldn't be used. Use TextFieldParser instead. This component was deprecated after 0.10.1.

line 16 col 16: 'Text' is deprecated and shouldn't be used. Use TextField instead. This component was deprecated after 0.10.1.

Fix lib/src/components/check_box/check_box.g.dart. (-0.50 points)

Analysis of lib/src/components/check_box/check_box.g.dart reported 1 hint:

line 3 col 8: Unused import: 'package:flutter_dynamic_forms_components/flutter_dynamic_forms_components.dart'.

Fix lib/src/components/container/container.g.dart. (-0.50 points)

Analysis of lib/src/components/container/container.g.dart reported 1 hint:

line 3 col 8: Unused import: 'package:flutter_dynamic_forms_components/flutter_dynamic_forms_components.dart'.

Fix additional 36 files with analysis or formatting issues. (-5 points)

Additional issues in the following files:

  • lib/src/components/date/date.g.dart (1 hint)
  • lib/src/components/date_range_picker/date_range.g.dart (1 hint)
  • lib/src/components/label/label.g.dart (1 hint)
  • lib/src/components/multi_select_choice/multi_select_choice.g.dart (1 hint)
  • lib/src/components/single_select_choice/single_select_choice.g.dart (1 hint)
  • lib/src/components/slider/slider.g.dart (1 hint)
  • lib/src/components/text/text.dart (1 hint)
  • lib/src/components/text/text_widget.dart (1 hint)
  • lib/src/default_renderers.dart (1 hint)
  • lib/src/reactive_renderers.dart (1 hint)
  • lib/src/components/check_box/check_box_parser.g.dart (Run flutter format to format lib/src/components/check_box/check_box_parser.g.dart.)
  • lib/src/components/container/container_parser.g.dart (Run flutter format to format lib/src/components/container/container_parser.g.dart.)
  • lib/src/components/date/date_parser.g.dart (Run flutter format to format lib/src/components/date/date_parser.g.dart.)
  • lib/src/components/date_range_picker/date_range_parser.g.dart (Run flutter format to format lib/src/components/date_range_picker/date_range_parser.g.dart.)
  • lib/src/components/dropdown_button/dropdown_button_parser.g.dart (Run flutter format to format lib/src/components/dropdown_button/dropdown_button_parser.g.dart.)
  • lib/src/components/dropdown_option/dropdown_option_parser.g.dart (Run flutter format to format lib/src/components/dropdown_option/dropdown_option_parser.g.dart.)
  • lib/src/components/form/form_parser.g.dart (Run flutter format to format lib/src/components/form/form_parser.g.dart.)
  • lib/src/components/form_group/form_group.g.dart (Run flutter format to format lib/src/components/form_group/form_group.g.dart.)
  • lib/src/components/form_group/form_group_parser.g.dart (Run flutter format to format lib/src/components/form_group/form_group_parser.g.dart.)
  • lib/src/components/label/label_parser.g.dart (Run flutter format to format lib/src/components/label/label_parser.g.dart.)
  • lib/src/components/multi_select_chip_choice/multi_select_chip_choice_parser.g.dart (Run flutter format to format lib/src/components/multi_select_chip_choice/multi_select_chip_choice_parser.g.dart.)
  • lib/src/components/multi_select_chip_group/multi_select_chip_group_parser.g.dart (Run flutter format to format lib/src/components/multi_select_chip_group/multi_select_chip_group_parser.g.dart.)
  • lib/src/components/multi_select_choice/multi_select_choice_parser.g.dart (Run flutter format to format lib/src/components/multi_select_choice/multi_select_choice_parser.g.dart.)
  • lib/src/components/multi_select_group/multi_select_group.g.dart (Run flutter format to format lib/src/components/multi_select_group/multi_select_group.g.dart.)
  • lib/src/components/multi_select_group/multi_select_group_parser.g.dart (Run flutter format to format lib/src/components/multi_select_group/multi_select_group_parser.g.dart.)
  • lib/src/components/radio_button/radio_button_parser.g.dart (Run flutter format to format lib/src/components/radio_button/radio_button_parser.g.dart.)
  • lib/src/components/radio_button_group/radio_button_group.g.dart (Run flutter format to format lib/src/components/radio_button_group/radio_button_group.g.dart.)
  • lib/src/components/radio_button_group/radio_button_group_parser.g.dart (Run flutter format to format lib/src/components/radio_button_group/radio_button_group_parser.g.dart.)
  • lib/src/components/single_select_chip_choice/single_select_chip_choice_parser.g.dart (Run flutter format to format lib/src/components/single_select_chip_choice/single_select_chip_choice_parser.g.dart.)
  • lib/src/components/single_select_chip_group/single_select_chip_group_parser.g.dart (Run flutter format to format lib/src/components/single_select_chip_group/single_select_chip_group_parser.g.dart.)
  • lib/src/components/single_select_choice/single_select_choice_parser.g.dart (Run flutter format to format lib/src/components/single_select_choice/single_select_choice_parser.g.dart.)
  • lib/src/components/single_select_group/single_select_group.g.dart (Run flutter format to format lib/src/components/single_select_group/single_select_group.g.dart.)
  • lib/src/components/single_select_group/single_select_group_parser.g.dart (Run flutter format to format lib/src/components/single_select_group/single_select_group_parser.g.dart.)
  • lib/src/components/slider/slider_parser.g.dart (Run flutter format to format lib/src/components/slider/slider_parser.g.dart.)
  • lib/src/components/text_field/text_field.g.dart (Run flutter format to format lib/src/components/text_field/text_field.g.dart.)
  • lib/src/components/text_field/text_field_parser.g.dart (Run flutter format to format lib/src/components/text_field/text_field_parser.g.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
dynamic_forms ^0.11.0 0.11.0
expression_language ^0.2.1 0.2.1
flutter 0.0.0
flutter_dynamic_forms ^0.11.0 0.11.0
intl ^0.16.0 0.16.1
meta ^1.1.8 1.1.8
rxdart ^0.23.1 0.23.1
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
matcher 0.12.6
path 1.6.4
petitparser 2.4.0 3.0.0
quiver 2.1.2+1
rational 0.3.7
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
uuid 2.0.4
vector_math 2.0.8
xml 3.6.1 3.7.0
Dev dependencies
build_runner ^1.0.0
dynamic_forms_generator ^0.6.0
flutter_test
pedantic ^1.8.0+1