flutter_dynamic_forms 0.11.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

flutter_dynamic_forms #

pub package

A flutter project providing infrastructure to render dynamic forms.

0.11.0 #

Incremented dependency on dynamic_forms package.

0.10.1 #

Fixed analyzer issues.

0.10.0 #

  • Incremented dependency on dynamic_forms package.
  • Increased minimum dart SDK to 2.6.0.

0.9.0 #

Incremented dependency on dynamic_forms package.

0.8.0 #

Incremented dependency on dynamic_forms package.

0.7.1 #

Fixed stream subscription in LazyStreamBuilder.

0.7.0 #

Incremented dependency on dynamic_forms package with new model names.

0.6.0 #

Incremented dependency on dynamic_forms package.

0.5.0 #

Incremented dependency on dynamic_forms package.

0.4.0 #

Small API changes.

0.3.0 #

Renderers were moved to the flutter_dynamic_forms_components package.

0.2.0 #

FormElementEvent API changes.

0.1.0 #

Initial Version of the library.

example/README.md

Example for flutter_dynamic_forms project #

Simple example with custom components.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_dynamic_forms: ^0.11.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_dynamic_forms/flutter_dynamic_forms.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
64
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Jan 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
dynamic_forms ^0.11.0 0.11.0
flutter 0.0.0
meta ^1.1.8 1.1.8
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
expression_language 0.2.1
matcher 0.12.6
path 1.6.4
petitparser 2.4.0 3.0.0
quiver 2.1.2+1
rational 0.3.7
rxdart 0.23.1
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
uuid 2.0.4
vector_math 2.0.8
xml 3.6.1 3.7.0
Dev dependencies
flutter_test
pedantic ^1.8.0+1