flutter_dtx 1.0.3
flutter_dtx: ^1.0.3 copied to clipboard

Flutter Android iOS web

Flutter package for Basic dart extension functions, can make use development speed fast

9
likes
100 / 110
pub points
0 %
popularity

We analyzed this package on Jan 21, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 144 API elements (22.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The declaration 'getEnumName' isn't referenced.

lib/flutter_dtx.dart:241:10

    ╷
241 │   String getEnumName(){
    │          ^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_dtx.dart

lib/flutter_dtx.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
intl^0.16.00.16.10.16.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.7.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
100
pub points
0%
popularity

Flutter package for Basic dart extension functions, can make use development speed fast

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jignesh.shakya1997pro@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on flutter_dtx