flutter_dropzone_web 2.1.1 copy "flutter_dropzone_web: ^2.1.1" to clipboard
flutter_dropzone_web: ^2.1.1 copied to clipboard

outdated

A drag-and-drop Flutter plugin (Web only).

2
likes
60/ 140
pub points
82%
popularity

We analyzed this package 2 days ago, and awarded it 60 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 52 API elements (46.2 %) have documentation comments.

Some symbols that are missing documentation: flutter_dropzone_plugin, flutter_dropzone_plugin.FlutterDropzonePlugin, flutter_dropzone_plugin.FlutterDropzonePlugin.FlutterDropzonePlugin, flutter_dropzone_plugin.FlutterDropzonePlugin.dispose, flutter_dropzone_plugin.FlutterDropzonePlugin.events.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_dropzone_web/flutter_dropzone_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:flutter_dropzone_web/flutter_dropzone_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:flutter_dropzone_web/flutter_dropzone_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_dropzone_web/flutter_dropzone_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_dropzone_web/flutter_dropzone_web.dart that declares support for platforms: Web.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

ERROR: 'FlutterDropzonePlugin.pickFiles' ('Future

lib/flutter_dropzone_plugin.dart:61:25

   ╷
61 │   Future<List<dynamic>> pickFiles(bool multiple, {required int viewId}) {
   │                         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_dropzone_plugin.dart

INFO: The import of 'dart:typed_data' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/foundation.dart'.

lib/flutter_dropzone_plugin.dart:3:8

  ╷
3 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_dropzone_plugin.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_dropzone_platform_interface ^2.0.0 2.0.6 2.0.6
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.6.3 0.6.7 0.7.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.