flutter_dropzone_platform_interface 1.0.2

  • Readme
  • Changelog
  • Installing
  • 80

flutter_dropzone_platform_interface #

A common platform interface for the flutter_dropzone plugin.

This interface allows platform-specific implementations of the flutter_dropzone plugin, as well as the plugin itself, to ensure they are supporting the same interface.

Usage #

To implement a new platform-specific implementation of flutter_dropzone, extend FlutterDropzonePlatform with an implementation that performs the platform-specific behavior, and when you register your plugin, set the default FlutterDropzonePlatform by calling FlutterDropzonePlatform.instance = FlutterDropzonePlugin().

Note on breaking changes #

Strongly prefer non-breaking changes (such as adding a method to the interface) over breaking changes for this package.

See https://flutter.dev/go/platform-interface-breaking-changes for a discussion on why a less-clean interface is preferable to a breaking change.

[1.0.2] - 2020-06-18 #

  • Support for onLeave #2.

[1.0.1] - 2020-06-18 #

  • Support for onHover #2.

[1.0.0] - 2020-05-29 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_dropzone_platform_interface: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_dropzone_platform_interface/flutter_dropzone_platform_interface.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
64
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • flutter_dropzone_platform_interface that is a package requiring null.

Health suggestions

Format lib/flutter_dropzone_platform_interface.dart.

Run flutter format to format lib/flutter_dropzone_platform_interface.dart.

Format lib/method_channel_flutter_dropzone.dart.

Run flutter format to format lib/method_channel_flutter_dropzone.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_dropzone_platform_interface.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
plugin_platform_interface ^1.0.1 1.0.2
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test
pedantic ^1.9.0