flutter_dialpad_plus 0.2.1
flutter_dialpad_plus: ^0.2.1 copied to clipboard

A phone dialer widget that can be added to Flutter App to enable ability to dial a number. This could be combined with a voip app or with any API e.g WhatsApp API.

2
likes
70/ 130
pub points
63%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://flutterer.Dev was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 25 API elements (12.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_dialpad_plus/flutter_dialpad_plus.dart that imports:
  • package:flutter_dtmf/flutter_dtmf.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_dtmf^0.0.30.0.41.0.2
flutter_masked_text^0.8.00.8.00.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.3` on flutter_dtmf does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions flutter_dtmf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

2
likes
70
pub points
63%
popularity

Publisher

flutterer.dev

A phone dialer widget that can be added to Flutter App to enable ability to dial a number. This could be combined with a voip app or with any API e.g WhatsApp API.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_dtmf, flutter_masked_text

More

Packages that depend on flutter_dialpad_plus