flutter_dialpad 1.0.0
flutter_dialpad: ^1.0.0 copied to clipboard

Flutter Android iOS

A phone dialer widget that can be added to any Flutter Application to enable ability to dial a number. This could be combined with a voip application to enable placing calls.

8
likes
70 / 110
pub points
72 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 24 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_dialpad/flutter_dialpad.dart that imports:
  • package:flutter_dtmf/flutter_dtmf.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/flutter_dialpad.dart:69:16

   ╷
69 │     var rows = List<Widget>();
   │                ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_dialpad.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/flutter_dialpad.dart:70:17

   ╷
70 │     var items = List<Widget>();
   │                 ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_dialpad.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_dtmf^0.0.30.0.41.0.0
flutter_masked_text^0.8.00.8.00.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.3` on flutter_dtmf does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions flutter_dtmf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

8
likes
70
pub points
72%
popularity

A phone dialer widget that can be added to any Flutter Application to enable ability to dial a number. This could be combined with a voip application to enable placing calls.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

eopeter@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, flutter_dtmf, flutter_masked_text

More

Packages that depend on flutter_dialpad