flutter_dialpad 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 85

flutter_dialpad #

A phone dialer widget that can be added to any Flutter Application to enable ability to dial a number. This could be combined with a voip application to enable placing calls.

This is a purely Dart widget with no dependency on Android or iOS except for the flutter_dtmf package it uses for DTMF tone generation on pressing a button. You can turn it off my setting enableDtmf: false

Getting Started #

@override
  Widget build(BuildContext context) {
    return Scaffold(
      backgroundColor: Colors.black,
      body: SafeArea(
        child:
            DialPad(
                enableDtmf: true,
                backspaceButtonIconColor: Colors.red,
                makeCall: (number){
                    print(number);
                }
            )
        ),
    );
  }

Screenshots #

iOS ScreenshotAndroid Screenshot
iOS ScreenshotAndroid Screenshot

To Do #

[Done] Add DTMF Tones

  • Shrink Ouput to Fit
  • Support for Local Numbers in Text Input Mask

[1.0.0] - 2020-04-19 #

  • Updated Example

[0.0.6+2] - 2020-03-19 #

  • Dependencies Update

[0.0.6+1] - 2019-07-28 #

  • Make Textfield for output readonly

[0.0.6] - 2019-07-28 #

  • Added Option to not animate dial button onTap

[0.0.5] - 2019-07-27 #

  • Fix issue where dial button event is not fired

[0.0.4] - 2019-07-27 #

  • Added DTMF Tone and Option to Turn it Off

[0.0.3] - 2019-07-26 #

  • Added Example and Overflow Bug Fix

[0.0.2] - 2019-07-26 #

  • Clean up code per pub.dev suggestions

[0.0.1] - 2019-07-26 #

  • Initial Release of the Flutter Dial Pad Widget

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_dialpad/flutter_dialpad.dart';


void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        backgroundColor: Colors.black,
        body: SafeArea(
            child:
            DialPad(
                enableDtmf: true,
                outputMask: "(000) 000-0000",
                backspaceButtonIconColor: Colors.red,
                makeCall: (number){
                  print(number);
                }
            )
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_dialpad: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_dialpad/flutter_dialpad.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:flutter_dialpad/flutter_dialpad.dart, package:flutter_dtmf/flutter_dtmf.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:flutter_dialpad/flutter_dialpad.dart, package:flutter_dtmf/flutter_dtmf.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:flutter_dialpad/flutter_dialpad.dart, package:flutter_dtmf/flutter_dtmf.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:flutter_dialpad/flutter_dialpad.dart, package:flutter_dtmf/flutter_dtmf.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [flutter_dialpad] that is in a package requiring null.

Health suggestions

Format lib/flutter_dialpad.dart.

Run flutter format to format lib/flutter_dialpad.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
flutter_dtmf ^0.0.3 0.0.3
flutter_masked_text ^0.8.0 0.8.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test