flutter_custom_theme 0.2.1 copy "flutter_custom_theme: ^0.2.1" to clipboard
flutter_custom_theme: ^0.2.1 copied to clipboard

Make your own custom theme for custom components. Easily share it between projects and customize.

14
likes
130/ 140
pub points
76%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/Innim/flutter_custom_theme/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 22 API elements (72.7 %) have documentation comments.

Some symbols that are missing documentation: flutter_custom_theme, flutter_custom_theme.ComplexCustomThemeData.ComplexCustomThemeData.by, flutter_custom_theme.ComplexCustomThemeData.ComplexCustomThemeData.safe, flutter_custom_theme.CustomThemeDataSet.data, flutter_custom_theme.CustomThemeDataSet.dataDark.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:flutter/widgets.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/custom_themes.dart:2:8

  ╷
2 │ import 'package:flutter/widgets.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/custom_themes.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
list_ext ^1.0.0 1.0.6 1.0.6
meta ^1.2.3 1.11.0 1.14.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

14
likes
130
pub points
76%
popularity

Publisher

verified publisherinnim.ru

Make your own custom theme for custom components. Easily share it between projects and customize.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, list_ext, meta

More

Packages that depend on flutter_custom_theme