flutter_credit_card_detector 1.0.0
flutter_credit_card_detector: ^1.0.0 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Um pacote Flutter que permite você implementar facilmente a interface do usuário do cartão de crédito com a detecção do cartão.

10
likes
80 / 110
pub points
68 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 120 API elements (4.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'BlacklistingTextInputFormatter' is deprecated and shouldn't be used. Use FilteringTextInputFormatter.deny instead. This feature was deprecated after v1.20.0-1.0.pre..

lib/src/screens/credit_card_widget.dart:161:31

    ╷
161 │             inputFormatters: [BlacklistingTextInputFormatter(RegExp(r'[.,]'))],
    │                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/screens/credit_card_widget.dart

INFO: Avoid using unnecessary statements.

lib/src/screens/credit_card_widget.dart:180:21

    ╷
180 │                   ? null
    │                     ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/screens/credit_card_widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.2
flutterflutter0.0.00.0.0
flutter_masked_text^0.8.00.8.00.8.0
flutter_mobx^1.1.01.1.0+21.1.0+2
intl^0.16.00.16.10.17.0
mobx^1.1.11.2.1+41.2.1+4
mobx_codegen^1.0.31.1.21.1.2
provider^4.0.44.3.35.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
analyzer-0.41.21.1.0
args-2.0.02.0.0
async-2.5.02.5.0
build-1.6.21.6.3
build_resolvers-1.5.31.5.4
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.03.0.0
dart_style-1.3.121.3.14
file-6.1.06.1.0
glob-2.0.02.0.0
graphs-0.2.01.0.0
logging-1.0.01.0.0
meta-1.3.01.3.0
nested-1.0.01.0.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
sky_engine-0.0.990.0.99
source_gen-0.9.10+30.9.10+3
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

The constraint `^0.16.0` on intl does not support the stable version `0.17.0`, that was published 28 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

10
likes
80
pub points
68%
popularity

Um pacote Flutter que permite você implementar facilmente a interface do usuário do cartão de crédito com a detecção do cartão.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

weldonrafael@gmail.com

License

MIT (LICENSE)

Dependencies

cupertino_icons, flutter, flutter_masked_text, flutter_mobx, intl, mobx, mobx_codegen, provider

More

Packages that depend on flutter_credit_card_detector