flutter_contact 0.8.1+2
flutter_contact: ^0.8.1+2 copied to clipboard

A Flutter plugin to retrieve, create and save contacts and contact-related events on Android and iOS devices.

35
likes
90 / 130
pub points
92 %
popularity

We analyzed this package on May 6, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 245 API elements (10.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_contact/flutter_contact.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Close instances of `dart.core.Sink`.

lib/paging_iterable.dart:106:24

    ╷
106 │   StreamController<T>? _controller;
    │                        ^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/paging_iterable.dart

lib/group.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
dartxx^0.4.40.4.4+60.5.0+2
equatable^2.0.02.0.02.0.0
flexidate^0.4.40.4.4+50.5.0+1
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.17.0
logging^1.0.01.0.11.0.1
logging_config^0.6.70.6.7+60.6.7+6
quiver^3.0.03.0.13.0.1
uuid^3.0.13.0.43.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
clock-1.1.01.1.0
crypto-3.0.13.0.1
dartx-0.6.00.7.1
inflection3-0.5.3+20.5.3+2
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
recase-4.0.04.0.0
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
time-1.5.0-nullsafety.12.0.0
timezone-0.7.00.7.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.4` on dartxx does not support the stable version `0.5.0+1`.

Try running dart pub upgrade --major-versions dartxx to update the constraint.

The constraint `^0.4.4` on flexidate does not support the stable version `0.5.0+1`.

Try running dart pub upgrade --major-versions flexidate to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

35
likes
90
pub points
92%
popularity

Publisher

sunnyapp.co

A Flutter plugin to retrieve, create and save contacts and contact-related events on Android and iOS devices.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection, dartxx, equatable, flexidate, flutter, intl, logging, logging_config, quiver, uuid

More

Packages that depend on flutter_contact