flutter_code_scanner 0.0.1+4 copy "flutter_code_scanner: ^0.0.1+4" to clipboard
flutter_code_scanner: ^0.0.1+4 copied to clipboard

QR code scanner that can be embedded inside flutter. It can be use on Android, IOS, Web.

7
likes
110/ 140
pub points
48%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

273 out of 325 API elements (84.0 %) have documentation comments.

Some symbols that are missing documentation: ai_barcode_scanner, ai_barcode_scanner.AddressType.AddressType.fromRawValue, ai_barcode_scanner.BarcodeFormat.BarcodeFormat.fromRawValue, ai_barcode_scanner.BarcodeType.BarcodeType.fromRawValue, ai_barcode_scanner.CameraFacing.CameraFacing.fromRawValue.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_code_scanner/flutter_code_scanner.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_code_scanner/flutter_code_scanner.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_code_scanner/flutter_code_scanner.dart that declares support for platforms: Android, iOS, Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: AiBarcodeScanner.hasAppBar

lib/src/ai_barcode_scanner.dart:9:7

  ╷
9 │ class AiBarcodeScanner extends StatefulWidget {
  │       ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/ai_barcode_scanner.dart

WARNING: Missing case clause for 'hidden'.

lib/src/lifecycle_event_handler.dart:13:5

   ╷
13 │     switch (state) {
   │     ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/lifecycle_event_handler.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_test flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.6.3 0.6.7 0.7.1
mobile_scanner ^3.0.0 3.5.7 4.0.1
plugin_platform_interface ^2.1.4 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

The constraint `^3.0.0` on mobile_scanner does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions mobile_scanner to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

7
likes
110
pub points
48%
popularity

Publisher

unverified uploader

QR code scanner that can be embedded inside flutter. It can be use on Android, IOS, Web.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_test, flutter_web_plugins, js, mobile_scanner, plugin_platform_interface

More

Packages that depend on flutter_code_scanner