flutter_cipher 0.0.3
flutter_cipher: ^0.0.3 copied to clipboard

A new Flutter Cipher package.

0
likes
70 / 130
pub points
68 %
popularity

We analyzed this package on May 12, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 67 API elements (37.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Override `hashCode` if overriding `==`.

lib/src/encrypted.dart:41:17

   ╷
41 │   bool operator ==(other) {
   │                 ^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/encrypted.dart

lib/flutter_cipher.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.11.6.02.1.0
asn1lib^0.5.80.5.151.0.0
collection^1.14.111.15.01.15.0
flutterflutter0.0.00.0.0
pointycastle^1.0.11.0.23.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.5.1` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.5.8` on asn1lib does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions asn1lib to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.