A Bugfender Wrapper plugin (implementing native code) for Flutter Projects.
Note: This plugin was provided by the community, hence it is published "AS IS", our support might not always be able to help you.
Using the package #
pubspec.yaml and add add
dev_dependencies: flutter_test: sdk: flutter flutter_bugfender: git: https://github.com/bugfender/BugfenderSDK-Flutter/
flutter pub get (or ‘Packages Get’ in IntelliJ) to download the package.
lib/main.dart and add an import:
And in your main application builder:
You can also call:
- FlutterBugfender.log("Working fine!");
- FlutterBugfender.warn("Warning sent!");
- FlutterBugfender.error("Error sent!");
- FlutterBugfender.setDeviceString("user.email", "firstname.lastname@example.org");
- FlutterBugfender.sendIssue("Test Issue", "Issue description goes here!");
[1.0.0] - Swift support - breaking change
- replaced iOS SDK with Swift supported pod
- replaced example with iOS Swift project
[0.0.5] - minor fixes
- added environment variable in pubspec.yaml (to be compatible with latest the flutter version)
- added ObjC dependency in podspec (in order for the iOS side to work)
- removed manual BugfenderSDK pod version number override (to pull the latest automatically, currently 1.6.3 instead 1.5.2)
Demonstrates how to use the flutter_bugfender plugin with Swift Bugfender SDK.
Getting Started #
For help getting started with Flutter, view our online documentation.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: flutter_bugfender: ^1.0.0
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.4
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.