flutter_bmflocation 1.0.4
flutter_bmflocation: ^1.0.4 copied to clipboard

BaiduMapLocation plugin for flutter. This plugin provides a cross-platform (iOS, Android) API to request location.

9
likes
85 / 130
pub points
84 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 85 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 109 API elements (79.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_bmflocation/bdmap_location_flutter_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_baidu_mapapi_base^2.0.12.0.12.0.1
permission_handler^5.0.1+15.1.0+28.1.4+1
uuid^2.0.12.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
meta-1.3.01.7.0
permission_handler_platform_interface-2.0.23.6.1
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.1+1` on permission_handler does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

The constraint `^2.0.1` on uuid does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

9
likes
85
pub points
84%
popularity

BaiduMapLocation plugin for flutter. This plugin provides a cross-platform (iOS, Android) API to request location.

Homepage

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, flutter_baidu_mapapi_base, permission_handler, uuid

More

Packages that depend on flutter_bmflocation