flutter_blue_pro 1.0.3 copy "flutter_blue_pro: ^1.0.3" to clipboard
flutter_blue_pro: ^1.0.3 copied to clipboard

Flutter plugin for connecting and communicationg with Bluetooth Low Energy devices, on Android and iOS

1
likes
130/ 160
pub points
60%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_blue_pro,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: flutter_blue_pro.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1649 out of 2587 API elements (63.7 %) have documentation comments.

Some symbols that are missing documentation: flutter_blue_pro, flutter_blue_pro.AdvertisementData, flutter_blue_pro.AdvertisementData.connectable, flutter_blue_pro.AdvertisementData.AdvertisementData.fromProto, flutter_blue_pro.AdvertisementData.localName.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_blue_pro/flutter_blue_pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_blue_pro/flutter_blue_pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_blue_pro/flutter_blue_pro.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_blue_pro/flutter_blue_pro.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/gen/flutterblueplus.pb.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/gen/flutterblueplus.pb.dart

INFO: Dangling library doc comment.

lib/gen/flutterblueplus.pbenum.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/gen/flutterblueplus.pbenum.dart

OK
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.19.0
convert ^3.0.1 3.1.1 3.1.1
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.12.0 1.15.0
protobuf ^2.0.1 2.1.0 3.1.0
rxdart ^0.27.5 0.27.7 0.28.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
fixnum - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

The constraint `^0.27.5` on rxdart does not support the stable version `0.28.0`, that was published 0 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
130
pub points
60%
popularity

Publisher

unverified uploader

Flutter plugin for connecting and communicationg with Bluetooth Low Energy devices, on Android and iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, convert, flutter, meta, protobuf, rxdart

More

Packages that depend on flutter_blue_pro