flutter_bloc_monitor 1.0.3+1
flutter_bloc_monitor: ^1.0.3+1 copied to clipboard

Flutter bloc monitor is as the name says, a monitor for the great flutter_bloc library. You can easyli monitor all your blocs activities in an easy way.

2
likes
100 / 130
pub points
66 %
popularity

We analyzed this package on May 12, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 52 API elements (28.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convex_bottom_bar^2.3.02.7.1+23.0.0
flutterflutter0.0.00.0.0
flutter_bloc^6.0.16.1.37.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
bloc-6.1.37.0.0
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
nested-1.0.01.0.0
provider-4.3.35.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.3.0` on convex_bottom_bar does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convex_bottom_bar to update the constraint.

The constraint `^6.0.1` on flutter_bloc does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

2
likes
100
pub points
66%
popularity

Flutter bloc monitor is as the name says, a monitor for the great flutter_bloc library. You can easyli monitor all your blocs activities in an easy way.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

rodrigobastosv@gmail.com

License

LICENSE

Dependencies

convex_bottom_bar, flutter, flutter_bloc

More

Packages that depend on flutter_bloc_monitor