flutter_bloc_cracker 0.0.7

Flutter Android iOS web

An interesting state management framework that helps implement BLoC (Business Logic Components).

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 34 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

WARNING: The parameter 'create' is required.

lib/src/bloc_provider.dart:28:41

   ╷
28 │   Widget build(BuildContext context) => Provider<Bloc>(
   │                                         ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc_provider.dart

INFO: 'builder' is deprecated and shouldn't be used. Will be removed as part of 4.0.0, use create instead.

lib/src/bloc_provider.dart:29:9

   ╷
29 │         builder: (_) => bloc,
   │         ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc_provider.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.1.71.1.81.2.3
provider^3.1.0+13.2.04.3.2+2
rxdart^0.22.40.22.60.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.0+1` on provider does not support the latest published version `4.3.2+2`

pubspec.yaml:14:13

   ╷
14 │   provider: ^3.1.0+1
   │             ^^^^^^^^
   ╵
The constraint `^0.22.4` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:13:11

   ╷
13 │   rxdart: ^0.22.4
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

Publisher

smallcpp.cn

An interesting state management framework that helps implement BLoC (Business Logic Components).

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, meta, provider, rxdart

More

Packages that depend on flutter_bloc_cracker