flutter_ble 0.5.3
flutter_ble: ^0.5.3 copied to clipboard

Flutter Android iOS

A new Flutter plugin for longev.ai.

5
likes
55 / 110
pub points
70 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.longev.ai/open-source/flutter_ble was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:7:41

  ╷
7 │ <p>FlutterBle is a bluetooth plugin for <a href="http://www.flutter.io">Flutter</a>, a new mobile SDK to help developers build modern apps for iOS and Android.
  │                                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 100 out of 799 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_ble/flutter_ble.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: The diagnostic 'unused_shown_name' doesn't need to be ignored here because it's already being ignored.

lib/gen/flutterblue.pbenum.dart:7:42

  ╷
7 │ // ignore_for_file: UNDEFINED_SHOWN_NAME,UNUSED_SHOWN_NAME
  │                                          ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/gen/flutterblue.pbenum.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/bluetooth_descriptor.dart:8:21

  ╷
8 │   static final Guid CCCD = new Guid("00002902-0000-1000-8000-00805f9b34fb");
  │                     ^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bluetooth_descriptor.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.0
flutterflutter0.0.00.0.0
protobuf^0.13.110.13.16+12.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
fixnum-0.10.111.0.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`, that was published 26 days ago.

When convert is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^0.13.11` on protobuf does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

5
likes
55
pub points
70%
popularity

A new Flutter plugin for longev.ai.

Homepage

Documentation

API reference

Uploader

j@longev.ai

License

unknown (LICENSE)

Dependencies

convert, flutter, protobuf

More

Packages that depend on flutter_ble