flutter_baidu_mapapi_utils 2.0.1
flutter_baidu_mapapi_utils: ^2.0.1 copied to clipboard

The flutter_bmfutils can be uesed to start baidu map client, Longitude and latitude convert, distance calculation between points,and so on.

3
likes
90 / 130
pub points
83 %
popularity

We analyzed this package on Jul 29, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 113 out of 131 API elements (86.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_baidu_mapapi_utils/flutter_baidu_mapapi_utils.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_baidu_mapapi_base^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

3
likes
90
pub points
83%
popularity

The flutter_bmfutils can be uesed to start baidu map client, Longitude and latitude convert, distance calculation between points,and so on.

Homepage

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, flutter_baidu_mapapi_base

More

Packages that depend on flutter_baidu_mapapi_utils