flutter_automation 1.2.1

Flutter Automation #

This package contains various automation scripts that will help you automate various aspects of your flutter project.

Usage #

To use this plugin, add flutter_automation as a dependency in your pubspec.yaml file.

Running scripts #

From terminal in your flutter project run,

flutter pub pub run flutter_automation --firebase-auth --google-maps --android-sign --firestore-crud

1. Firebase Auth #

This sets up firebase authentication with google and email based login automatically in your flutter project. Also copies boilerplate login ui flow using provider package for state management

flutter pub pub run flutter_automation --firebase-auth

2. Google Maps #

sets up google maps flutter plugin on android platform in a flutter project.

After you run the script in your flutter project you need to modify android/app/src/main/res/values/strings.xml file changing the text YOUR_API_KEY to your actual google maps Api key.

flutter pub pub run flutter_automation --google-maps

3. Android Signing #

Generates keystore and sets up android signing config in your flutter project.

It uses keytool to generate keystore so, for this script to work keytool must be in path.

flutter pub pub run flutter_automation --android-sign

4. Firestore CRUD #

Provides a simple firestore CRUD operation boilerplate

flutter pub pub run flutter_automation --firestore-crud

[1.1.4] - Changes in stock files

  • Bug fixing
  • Certain validations
  • Stock files updated, renamed .temp to prevent analysis of while publishing

[1.2.0] - Firestore CRUD boilerplate

  • Firestore CRUD boilerplate automation

[1.2.1]

  • fixing bugs

example/README.md

Flutter Automation #

This package contains various automation scripts that will help you automate various aspects of your flutter project.

Usage #

To use this plugin, add flutter_automation as a dependency in your pubspec.yaml file.

Running scripts #

From terminal in your flutter project run,

flutter pub pub run flutter_automation --firebase-auth --google-maps --android-sign --firestore-crud

1. Firebase Auth #

This sets up firebase authentication with google and email based login automatically in your flutter project. Also copies boilerplate login ui flow using provider package for state management

flutter pub pub run flutter_automation --firebase-auth

2. Google Maps #

sets up google maps flutter plugin on android platform in a flutter project.

After you run the script in your flutter project you need to modify android/app/src/main/res/values/strings.xml file changing the text YOUR_API_KEY to your actual google maps Api key.

flutter pub pub run flutter_automation --google-maps

3. Android Signing #

Generates keystore and sets up android signing config in your flutter project.

It uses keytool to generate keystore so, for this script to work keytool must be in path.

flutter pub pub run flutter_automation --android-sign

4. Firestore CRUD #

Provides a simple firestore CRUD operation boilerplate

flutter pub pub run flutter_automation --firestore-crud

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_automation: ^1.2.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_automation/flutter_automation.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

47 out of 47 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/commons.dart.

Run flutter format to format lib/commons.dart.

Format lib/firebase_auth.dart.

Run flutter format to format lib/firebase_auth.dart.

Format lib/firestore_crud.dart.

Run flutter format to format lib/firestore_crud.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
args ^1.5.2 1.5.2
flutter 0.0.0
path ^1.6.2 1.6.4
yaml ^2.1.16 2.1.16
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test