flutter_armod_widget 2.0.0-pre.12 copy "flutter_armod_widget: ^2.0.0-pre.12" to clipboard
flutter_armod_widget: ^2.0.0-pre.12 copied to clipboard

Flutter AR-MOD SDK widget for embedding AR(Augmented Reality) features in flutter.

9
likes
140/ 160
pub points
54%
popularity

We analyzed this package 32 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

80 out of 183 API elements (43.7 %) have documentation comments.

Some symbols that are missing documentation: flutter_armod_widget, flutter_armod_widget.ARMODCreatedCallback, flutter_armod_widget.ARMODEvent, flutter_armod_widget.ARMODEvent.ARMODEvent, flutter_armod_widget.ARMODExitCallback.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_armod_widget/flutter_armod_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_armod_widget/flutter_armod_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_armod_widget/flutter_armod_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_armod_widget/flutter_armod_widget.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 61 issues. Showing the first 2:

WARNING: Braces unnecessarily wrap this expression in a set literal.

lib/src/controller.dart:79:37

   ╷
79 │             .listen((ARMODEvent e) => {
   │ ┌─────────────────────────────────────^
80 │ │                 _armodWidgetState
81 │ │                     .widget.onUpdateLoadingProgress!(e.value1['progress']),
82 │ │               });
   │ └───────────────^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

WARNING: Braces unnecessarily wrap this expression in a set literal.

lib/src/controller.dart:130:54

    ╷
130 │             .listen((tryAcquireInformation e) async => {
    │ ┌──────────────────────────────────────────────────────^
131 │ │                 result = await _armodWidgetState
132 │ │                     .widget.onTryAcquireInformation!(e.value1['opTag']),
133 │ │                 if (!willbeDisposed) e.callback(result),
134 │ │               });
    │ └───────────────^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controller.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.3 2.0.20 2.0.20
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
stream_transform ^2.0.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

9
likes
140
pub points
54%
popularity

Publisher

unverified uploader

Flutter AR-MOD SDK widget for embedding AR(Augmented Reality) features in flutter.

Homepage

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_plugin_android_lifecycle, plugin_platform_interface, stream_transform

More

Packages that depend on flutter_armod_widget