flutter_app_package 1.0.0+1 flutter_app_package: ^1.0.0+1 copied to clipboard
A new Flutter application.
We analyzed this package 1 hour ago, and awarded it 85 pub points (of a possible 140):
0/10 points: Provide a valid
The package description is too short.
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
5/5 points: Provide a valid
0/5 points: Provide a valid
No `CHANGELOG.md` found.
Changelog entries help developers follow the progress of your package. See the example generated by
0/10 points: Use an OSI-approved license
No license was recognized.
Consider using an OSI-approved license in the
LICENSE file to make it more accessible to the community.
10/10 points: Package has an example
10/10 points: 20% or more of the public API has dartdoc comments
- 2 out of 9 API elements (22.2 %) have documentation comments.
20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)
- ✓ Android
- ✓ iOS
- ✓ Windows
- ✓ Linux
- ✓ MacOS
- ✓ Web
20/30 points: code has no errors, warnings, lints, or formatting issues
INFO: 'headline4' is deprecated and shouldn't be used. Use headlineMedium instead. This feature was deprecated after v3.1.0-0.0.pre.
╷ 101 │ style: Theme.of(context).textTheme.headline4, │ ^^^^^^^^^ ╵
To reproduce make sure you are using the lints_core and run
flutter analyze lib/main.dart
10/10 points: All of the package dependencies are supported in the latest version
To reproduce run
dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.
10/10 points: Package supports latest stable Dart and Flutter SDKs
0/20 points: Package does not opt in to null safety.
Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.
Analysed with Pana