flutter_app_name 0.1.1 copy "flutter_app_name: ^0.1.1" to clipboard
flutter_app_name: ^0.1.1 copied to clipboard

A package that makes it easy to set your flutter app launcher name.

126
likes
90/ 140
pub points
92%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 23 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: android, android.fetchCurrentBundleName, android.setNewBundleName, android.updateLauncherName, common.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_app_name/flutter_app_name.dart that imports:
  • package:flutter_app_name/android.dart that imports:
  • package:flutter_app_name/common.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Unused import: 'dart:io'.

lib/android.dart:1:8

  ╷
1 │ import "dart:io";
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/android.dart

WARNING: Unused import: 'dart:io'.

lib/ios.dart:1:8

  ╷
1 │ import "dart:io";
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/ios.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
xml ^5.1.2 5.4.1 6.5.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
petitparser - 5.4.0 6.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.1.2` on xml does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

126
likes
90
pub points
92%
popularity

Publisher

unverified uploader

A package that makes it easy to set your flutter app launcher name.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

xml, yaml

More

Packages that depend on flutter_app_name