flutter_apns_only 1.6.0 copy "flutter_apns_only: ^1.6.0" to clipboard
flutter_apns_only: ^1.6.0 copied to clipboard

discontinued
PlatformiOS

APNS push notification plugin. Works only on iOS. See flutter_apns for apns & firebase combo

9
likes
120/ 140
pub points
88%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 46 API elements (23.9 %) have documentation comments.

Some symbols that are missing documentation: flutter_apns_only, flutter_apns_only.ApnsAuthorizationStatus, flutter_apns_only.ApnsAuthorizationStatus.ApnsAuthorizationStatus, flutter_apns_only.ApnsMessageHandler, flutter_apns_only.ApnsPushConnectorOnly.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:flutter_apns_only/flutter_apns_only.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:flutter_apns_only/flutter_apns_only.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_apns_only/flutter_apns_only.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_apns_only/flutter_apns_only.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_apns_only/flutter_apns_only.dart that declares support for platforms: iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_apns_only.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

9
likes
120
pub points
88%
popularity

Publisher

unverified uploader

APNS push notification plugin. Works only on iOS. See flutter_apns for apns & firebase combo

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_apns_only