flutter_api_manager 1.0.0 copy "flutter_api_manager: ^1.0.0" to clipboard
flutter_api_manager: ^1.0.0 copied to clipboard

APIManager-Flutter is a flutter library that can manage the API calls from a single place.

3
likes
140/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 23 API elements (69.6 %) have documentation comments.

Some symbols that are missing documentation: flutter_api_manager, flutter_api_manager.APIMethod, flutter_api_manager.Response.data, flutter_api_manager.Response.error, flutter_api_manager.Response.isSuccessful.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_api_manager/flutter_api_manager.dart that imports:
  • package:flutter_api_manager/src/api_manager.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that imports:
  • package:flutter_secure_storage_platform_interface/flutter_secure_storage_platform_interface.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: An uninitialized variable should have an explicit type annotation.

lib/src/api_manager.dart:176:9

    ╷
176 │     var response;
    │         ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api_manager.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/src/exception/exception.dart:4:9

  ╷
4 │   final data;
  │         ^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/exception/exception.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_secure_storage ^5.0.2 5.1.2 9.2.2
http ^0.13.4 0.13.6 1.2.2
http_parser ^4.0.0 4.0.2 4.1.0
mime ^1.0.1 1.0.5 1.0.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_secure_storage_linux - 1.2.1 1.2.1
flutter_secure_storage_macos - 1.1.2 3.1.2
flutter_secure_storage_platform_interface - 1.1.2 1.1.2
flutter_secure_storage_web - 1.2.1 1.2.1
flutter_secure_storage_windows - 1.1.3 3.1.2
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.2` on flutter_secure_storage does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
140
pub points
0%
popularity

Publisher

verified publisheriamdipanshus.in

APIManager-Flutter is a flutter library that can manage the API calls from a single place.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

Dependencies

flutter, flutter_secure_storage, http, http_parser, mime

More

Packages that depend on flutter_api_manager