flutter_analyze_reporter 0.1.2 copy "flutter_analyze_reporter: ^0.1.2" to clipboard
flutter_analyze_reporter: ^0.1.2 copied to clipboard

Parse Flutter analyze output to display it within GitLab Code Quality Widget

3
likes
140/ 140
pub points
47%
popularity

We analyzed this package 33 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/andnexus/flutter_analyze_reporter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 3 API elements (66.7 %) have documentation comments.

Some symbols that are missing documentation: flutter_analyze_reporter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_analyze_reporter/flutter_analyze_reporter.dart that imports:
  • package:flutter_analyze_reporter/src/cli_runner.dart that imports:
  • package:flutter_analyze_reporter/src/parser/flutter_analyze_parser.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.1 2.0.2 2.0.2
args ^2.4.1 2.5.0 2.5.0
crypto ^3.0.3 3.0.3 3.0.3
flutter flutter 0.0.0 0.0.0
xml ^6.3.0 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
petitparser - 6.0.2 6.0.2
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

3
likes
140
pub points
47%
popularity

Publisher

verified publisherandnexus.com

Parse Flutter analyze output to display it within GitLab Code Quality Widget

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ansicolor, args, crypto, flutter, xml

More

Packages that depend on flutter_analyze_reporter