flutter_analyze_reporter 0.1.2 copy "flutter_analyze_reporter: ^0.1.2" to clipboard
flutter_analyze_reporter: ^0.1.2 copied to clipboard

Parse Flutter analyze output to display it within GitLab Code Quality Widget

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate flutter_analyze_reporter

Use it

The package has the following executables:

$ flutter_analyze_reporter

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add flutter_analyze_reporter

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  flutter_analyze_reporter: ^0.1.2

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:flutter_analyze_reporter/flutter_analyze_reporter.dart';
3
likes
140
pub points
47%
popularity

Publisher

verified publisherandnexus.com

Parse Flutter analyze output to display it within GitLab Code Quality Widget

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ansicolor, args, crypto, flutter, xml

More

Packages that depend on flutter_analyze_reporter