fluent_ui 4.8.7 copy "fluent_ui: ^4.8.7" to clipboard
fluent_ui: ^4.8.7 copied to clipboard

Implements Windows UI in Flutter. Based on the official documentation

2624
likes
130/ 140
pub points
97%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2862 out of 5714 API elements (50.1 %) have documentation comments.

Some symbols that are missing documentation: fluent_localizations, fluent_localizations.FluentLocalizations.delegate, fluent_localizations.FluentLocalizations.localeName, fluent_localizations.FluentLocalizations.of, fluent_localizations.lookupFluentLocalizations.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: Use 'TypeName _' instead of a type literal.

lib/src/controls/navigation/navigation_view/pane_items.dart:1017:14

     ╷
1017 │         case String:
     │              ^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controls/navigation/navigation_view/pane_items.dart

INFO: Use 'TypeName _' instead of a type literal.

lib/src/controls/navigation/navigation_view/pane_items.dart:1019:14

     ╷
1019 │         case InlineSpan:
     │              ^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/controls/navigation/navigation_view/pane_items.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
intl >=0.18.0 <=1.0.0 0.18.1 0.19.0
math_expressions ^2.4.0 2.5.0 2.5.0
recase ^4.1.0 4.1.0 4.1.0
scroll_pos >=0.5.0 <1.0.0 0.5.0 0.5.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.