flowder 0.2.0 copy "flowder: ^0.2.0" to clipboard
flowder: ^0.2.0 copied to clipboard

Persistent file downloader manager, start, pause, resume, cancel your download.

125
likes
80/ 140
pub points
85%
popularity

We analyzed this package 2 hours ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 26 API elements (96.2 %) have documentation comments.

Some symbols that are missing documentation: flowder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flowder/flowder.dart that imports:
  • package:flowder/src/flowder.dart that imports:
  • package:flowder/src/utils/utils.dart that imports:
  • package:flowder/src/utils/downloader_utils.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: Undefined class 'VoidCallback'.

lib/src/utils/downloader_utils.dart:23:9

   ╷
23 │   final VoidCallback onDone;
   │         ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/downloader_utils.dart

INFO: The import of 'package:flowder/src/utils/constants.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flowder/src/flowder.dart'.

lib/src/core/downloader_core.dart:4:8

  ╷
4 │ import 'package:flowder/src/utils/constants.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/core/downloader_core.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.0 4.0.6 5.4.3
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

125
likes
80
pub points
85%
popularity

Publisher

unverified uploader

Persistent file downloader manager, start, pause, resume, cancel your download.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dio, flutter, flutter_web_plugins

More

Packages that depend on flowder