flipper_util 1.0.3 copy "flipper_util: ^1.0.3" to clipboard
flipper_util: ^1.0.3 copied to clipboard

flutter plugin for flipperUtil

2
likes
85/ 140
pub points
4%
popularity

We analyzed this package 2 days ago, and awarded it 85 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

8 out of 51 API elements (15.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: api_generated, api_generated.FlipperDioApi, api_generated.FlipperDioApi.codec, api_generated.FlipperDioApi.reportRequest, api_generated.FlipperDioApi.reportResponse.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flipper_util/flipper_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flipper_util/flipper_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flipper_util/flipper_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flipper_util/flipper_util.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/flipperkit_dio_interceptor.dart:54:22

   ╷
54 │     if(options.extra == null){
   │                      ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flipperkit_dio_interceptor.dart

WARNING: The stack trace variable 's' isn't used and can be removed.

lib/flipperkit_dio_interceptor.dart:73:14

   ╷
73 │     }catch(e,s){
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flipperkit_dio_interceptor.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.0 4.0.6 5.4.1
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
uuid ^3.0.4 3.0.7 4.3.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^3.0.4` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.