flint 1.0.4

Flint: Because Pedantic wasn't strict enough #

Travis CI Pub Dev

Flint contains Forus Labs' different sets of dartanalyzer lints that we use internally in our Dart & Flutter projects.

Using the Lints #

To use the lints, add a dependency in your pubspec.yaml.

dev_dependencies:
  flint: ^1.0.3  

Then, add the the set of lints to your analysis_options.yaml. The following will always include the latest version of the specified set of lints.

include: package:flint/dart/dev/analysis_options.yaml

A specific version of a set of lints can also be used via:

include: package:flint/dart/dev/analysis_options.1.0.3.yaml

The following sets of lints are available:

LintDescription
package:flint/dart/dev/analysis_options.yamlmaster branch of a Dart project
package:flint/dart/stable/analysis_options.yamlstable branch of a Dart project
package:flint/flutter/dev/analysis_options.yamlmaster branch of a Flutter project
package:flint/flutter/stable/analysis_options.yamlstable branch of a Flutter project

1.0.4 - Moar Fixes #

  • Fix parameter_assignment being enabled
  • Fix use_to_and_as_if_applicable being ignored

1.0.3 - Successive Refinement #

  • Fix avoid_renaming_method_parameters being enabled
  • Fix diagnostic_describe_all_properties being enabled

1.0.2 - Third's the charm? #

  • Add missing flint.dart file

1.0.1 - I swear it won't happen again #

  • Add example
  • Fix error in generation.dart
  • Fix package_api_docs being enabled in dev branches
  • Fix use_full_hex_values_for_flutter_colors being enabled in dart branches
  • Fix duplicate public_member_api_docs entry in dart/dev/analysis_options.yaml
  • Remove lib/flint.dart

1.0.0 - Initial Launch! 🚀 #

  • Add analysis_options.yaml for Dart & Flutter
  • Add auto-update tool for analysis_option.yaml

example/README.md

Please see Using the Lints

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flint: ^1.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flint/flint.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Feb 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health issues and suggestions

Document public APIs. (-1 points)

1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/flint.dart.

Run dartfmt to format lib/flint.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
Dev dependencies
meta ^1.1.7
yaml ^2.2.0