Flint - Because Pedantic wasn't strict enough

Travis CI Codecov Pub Dev Documentation

Forus Labs' dartanalyzer configurations that are used internally in our Dart & Flutter projects.

Please view the stable brunch for a production version.


Using the Lints

To use the lints, add the following dependency in your pubspec.yaml.

dev_dependencies:
  flint: ^1.0.6  

Then, add a configuration to your analysis_options.yaml. The following will always include the latest version of said set.

include: package:flint/dart/dev/analysis_options.yaml

A specific configuration version can be used via:

include: package:flint/dart/dev/analysis_options.1.0.6.yaml

Configurations

ConfigurationDescription
package:flint/dart/dev/analysis_options.yamlmaster branch of a Dart project
package:flint/dart/stable/analysis_options.yamlstaging and stable branch of a Dart project
package:flint/flutter/dev/analysis_options.yamlmaster branch of a Flutter project
package:flint/flutter/stable/analysis_options.yamlstaging and stable branch of a Flutter project

Libraries

flint
Forus Labs' dartanalyzer configurations that are used internally in Dart & Flutter projects.