flightmap_gl 0.1.1
flightmap_gl: ^0.1.1 copied to clipboard

A Flutter plugin for integrating Mapbox Maps inside a Flutter application on Android, iOS and web platfroms.

0
likes
80 / 130
pub points
20 %
popularity

We analyzed this package on Jun 27, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/karanveer0802/flightmapfluttersdk was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 70 out of 108 API elements (64.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flightmap_gl/flightmap_gl.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/controller.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/mapbox_map.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
mapbox_gl_platform_interface^0.7.00.7.00.12.0
mapbox_gl_web^0.7.00.7.00.12.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
flutter_web_plugins-0.0.00.0.0
image-2.1.193.0.2
js-0.6.30.6.3
mapbox_gl_dart-0.1.50.1.5
meta-1.3.01.4.0
path-1.8.01.8.0
petitparser-3.1.04.2.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-4.5.15.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.0` on mapbox_gl_platform_interface does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions mapbox_gl_platform_interface to update the constraint.

The constraint `^0.7.0` on mapbox_gl_web does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions mapbox_gl_web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

0
likes
80
pub points
20%
popularity

A Flutter plugin for integrating Mapbox Maps inside a Flutter application on Android, iOS and web platfroms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, mapbox_gl_platform_interface, mapbox_gl_web

More

Packages that depend on flightmap_gl