mapbox_gl_web 0.7.0

  • Readme
  • Changelog
  • Installing
  • 89

Contains the web interfaces for the Flutter Mapbox GL plugin.

0.7.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mapbox_gl_web: ^0.7.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mapbox_gl_web/mapbox_gl_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:mapbox_gl_web/mapbox_gl_web.dart that declares support for platforms: web

Package does not support Flutter platform ios

Because:

  • package:mapbox_gl_web/mapbox_gl_web.dart that declares support for platforms: web

Package does not support Flutter platform linux

Because:

  • package:mapbox_gl_web/mapbox_gl_web.dart that declares support for platforms: web

Package does not support Flutter platform macos

Because:

  • package:mapbox_gl_web/mapbox_gl_web.dart that declares support for platforms: web

Package does not support Flutter platform windows

Because:

  • package:mapbox_gl_web/mapbox_gl_web.dart that declares support for platforms: web

Package not compatible with SDK dart

Because:

  • mapbox_gl_web that is a package requiring null.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mapbox_gl_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_web_plugins 0.0.0
image ^2.1.12 2.1.14
mapbox_gl_dart ^0.1.5 0.1.5
mapbox_gl_platform_interface ^0.7.0 0.7.0
meta ^1.1.7 1.1.8 1.2.1
Transitive dependencies
archive 2.0.13
args 1.6.0
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
js 0.6.2
path 1.7.0
petitparser 3.0.4
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xml 4.2.0
Dev dependencies
flutter_test