flex 1.0.0 copy "flex: ^1.0.0" to clipboard
flex: ^1.0.0 copied to clipboard

A collection of classes, extensions and utilities to aid faster development.

1
likes
100/ 160
pub points
48%
popularity

We analyzed this package 1 hour ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://git.pfaff.dev/michael/flex was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://git.pfaff.dev/michael/flex/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1631 out of 1634 API elements (99.8 %) have documentation comments.

Some symbols that are missing documentation: flex.FallbackBuilder, flex.LineParser, flex.PatientStreamQueue.sync.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flex/flex.dart that imports:
  • package:flex/src/util.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

WARNING: Invalid option specified for 'enable-experiment': Flag "non-nullable" is no longer required.

lib/analysis_options.yaml:25:7

   ╷
25 │     - non-nullable
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/analysis_options.yaml

WARNING: 'sdk_version_async_exported_from_core' isn't a recognized error code.

lib/analysis_options.yaml:42:5

   ╷
42 │     sdk_version_async_exported_from_core: ignore
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/analysis_options.yaml

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
console ^4.1.0 4.1.0 4.1.0
intl ^0.17.0 0.17.0 0.19.0
io ^1.0.0 1.0.4 1.0.4
meta ^1.7.0 1.15.0 1.15.0
rxdart ^0.27.0 0.27.7 0.28.0
stack_trace ^1.10.0 1.11.1 1.11.1
tuple ^2.0.0 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

The constraint `^0.27.0` on rxdart does not support the stable version `0.28.0`, that was published 6 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • NON_ABSTRACT_CLASS_INHERITS_ABSTRACT_MEMBER - lib/src/patient_stream_queue.dart:13:7 - Missing concrete implementation of 'Subject.createForwardingSubject'.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

1
likes
100
pub points
48%
popularity

Publisher

verified publisherpfaff.dev

A collection of classes, extensions and utilities to aid faster development.

Homepage
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, console, intl, io, meta, rxdart, stack_trace, tuple

More

Packages that depend on flex