fl_location_web 3.0.0 copy "fl_location_web: ^3.0.0" to clipboard
fl_location_web: ^3.0.0 copied to clipboard

Platformweb

The web implementation of the fl_location plugin.

1
likes
140/ 160
pub points
45%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 10 API elements (60.0 %) have documentation comments.

Some symbols that are missing documentation: fl_location_web, fl_location_web.FlLocationWeb, fl_location_web.FlLocationWeb.FlLocationWeb, fl_location_web.FlLocationWeb.registerWith.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:fl_location_web/fl_location_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:fl_location_web/fl_location_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:fl_location_web/fl_location_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:fl_location_web/fl_location_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:fl_location_web/fl_location_web.dart that declares support for platforms: Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fl_location_platform_interface ^3.0.0 3.0.0 3.0.0
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
140
pub points
45%
popularity

Publisher

unverified uploader

The web implementation of the fl_location plugin.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

fl_location_platform_interface, flutter, flutter_web_plugins

More

Packages that depend on fl_location_web