fl_hive 0.0.3
fl_hive: ^0.0.3 copied to clipboard

Make Hive package super easy to use, with auto close box ability to improve performance

1
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 28, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 67 API elements (6.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async^2.4.22.8.22.8.2
flutterflutter0.0.00.0.0
hive^1.4.4+11.4.4+12.0.4
hive_flutter^0.3.10.3.11.1.0
rxdart^0.24.10.24.10.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-1.6.282.0.6
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.4.4+1` on hive does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions hive to update the constraint.

The constraint `^0.3.1` on hive_flutter does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions hive_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
90
pub points
0%
popularity

Make Hive package super easy to use, with auto close box ability to improve performance

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, flutter, hive, hive_flutter, rxdart

More

Packages that depend on fl_hive