firebase_remote_config 0.6.0
firebase_remote_config: ^0.6.0 copied to clipboard

Flutter plugin for Firebase Remote Config. Update your application look and feel and behaviour without re-releasing.

173
likes
90 / 130
pub points
98 %
popularity

We analyzed this package on May 14, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 45 API elements (55.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^0.7.00.7.01.1.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
firebase_core_platform_interface-3.0.14.0.1
firebase_core_web-0.2.1+31.0.3
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
plugin_platform_interface-1.0.32.0.0
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.0` on firebase_core does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

173
likes
90
pub points
98%
popularity

Publisher

firebase.google.com

Flutter plugin for Firebase Remote Config. Update your application look and feel and behaviour without re-releasing.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_core, flutter

More

Packages that depend on firebase_remote_config