firebase_performance_dio4 0.6.0 copy "firebase_performance_dio4: ^0.6.0" to clipboard
firebase_performance_dio4: ^0.6.0 copied to clipboard

Dio Firebase performance monitoring.

0
likes
110/ 140
pub points
23%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 11 API elements (36.4 %) have documentation comments.

Some symbols that are missing documentation: firebase_performance_dio, firebase_performance_dio.DioFirebasePerformanceInterceptor.requestContentLengthMethod, firebase_performance_dio.DioFirebasePerformanceInterceptor.responseContentLengthMethod, firebase_performance_dio.RequestContentLengthMethod, firebase_performance_dio.ResponseContentLengthMethod.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:firebase_performance_dio4/firebase_performance_dio.dart that imports:
  • package:firebase_performance_dio4/src/firebase_performance_dio.dart that imports:
  • package:firebase_performance/firebase_performance.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:firebase_performance_dio4/firebase_performance_dio.dart that imports:
  • package:firebase_performance_dio4/src/firebase_performance_dio.dart that imports:
  • package:firebase_performance/firebase_performance.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:firebase_performance_dio4/firebase_performance_dio.dart that imports:
  • package:firebase_performance_dio4/src/firebase_performance_dio.dart that imports:
  • package:firebase_performance/firebase_performance.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_performance_dio4/firebase_performance_dio.dart that imports:
  • package:firebase_performance_dio4/src/firebase_performance_dio.dart that imports:
  • package:firebase_performance/firebase_performance.dart that imports:
  • package:firebase_performance_platform_interface/firebase_performance_platform_interface.dart that imports:
  • package:firebase_performance_platform_interface/src/platform_interface/platform_interface_firebase_performance.dart that imports:
  • package:firebase_performance_platform_interface/src/method_channel/method_channel_firebase_performance.dart that imports:
  • package:firebase_performance_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:_flutterfire_internals/_flutterfire_internals.dart that imports:
  • package:_flutterfire_internals/src/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.0 4.0.6 5.4.1
firebase_performance >=0.8.0 <0.10.0 0.9.3+14 0.9.3+14
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.22 1.3.22
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core - 2.25.4 2.25.4
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.11.4 2.11.4
firebase_performance_platform_interface - 0.1.4+22 0.1.4+22
firebase_performance_web - 0.1.4+22 0.1.4+22
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
leak_tracker - 10.0.3 10.0.4
leak_tracker_flutter_testing - 3.0.2 3.0.3
leak_tracker_testing - 3.0.0 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.0.0 14.0.0
web - 0.4.2 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.