firebase_messaging 7.0.3
firebase_messaging: ^7.0.3 copied to clipboard

Flutter Android iOS

Flutter plugin for Firebase Cloud Messaging, a cross-platform messaging solution that lets you reliably deliver messages on Android and iOS.

936
likes
90 / 110
pub points
99 %
popularity

We analyzed this package on Jan 20, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 22 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_messaging/firebase_messaging.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^0.5.0+10.5.30.7.0
meta^1.0.41.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
firebase_core_platform_interface-2.1.03.0.1
firebase_core_web-0.2.1+10.2.1+3
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
path-1.7.01.8.0-nullsafety.3
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
stack_trace-1.9.61.10.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0+1` on firebase_core does not support the latest published version `0.7.0`

pubspec.yaml:20:18

   ╷
20 │   firebase_core: ^0.5.0+1
   │                  ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

936
likes
90
pub points
99%
popularity

Publisher

firebase.google.com

Flutter plugin for Firebase Cloud Messaging, a cross-platform messaging solution that lets you reliably deliver messages on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_core, flutter, meta

More

Packages that depend on firebase_messaging