firebase_messaging 7.0.0

Flutter Android iOS

Flutter plugin for Firebase Cloud Messaging, a cross-platform messaging solution that lets you reliably deliver messages on Android and iOS.

7.0.0 #

  • Depend on firebase_core and migrate plugin to use firebase_core native SDK versioning features;
    • Firebase iOS SDK versions are now locked to use the same version defined in firebase_core.
    • Firebase Android SDK versions are now using the Firebase Bill of Materials (BoM) to specify individual SDK versions. BoM version is also sourced from firebase_core.
  • Allow iOS to be imported as a module.

6.0.16 #

  • Fix push notifications clearing after app launch on iOS.

6.0.16 #

  • Update lower bound of dart dependency to 2.0.0.

6.0.15 #

  • Fix - register pluginRegistrantCallback on every FcmDartService#start call.

6.0.14 #

  • Fix for missing UserAgent.h compilation failures.

6.0.13 #

  • Implement UNUserNotificationCenterDelegate methods to allow plugin to work when method swizzling is disabled.
  • Applications now only need to update their iOS project's AppDelegate when method swizzling is disabled.
  • Applications that need to use firebase_messaging with other notification plugins will need to add the following to their iOS project's Info.plist file:
    <key>FirebaseAppDelegateProxyEnabled</key>
    <false/>
    

6.0.12 #

  • Replace deprecated getFlutterEngine call on Android.

6.0.11 #

  • Make the pedantic dev_dependency explicit.

6.0.10 #

  • Update README to explain how to correctly implement Android background message handling with the new v2 embedding.

6.0.9 #

  • Update Android Gradle plugin dependency to 3.5.3, update documentation and example.
  • Update google-services Android gradle plugin to 4.3.2 in documentation and examples.

6.0.8 #

  • Support for provisional notifications for iOS version >= 12.

6.0.7 #

  • Remove the deprecated author: field from pubspec.yaml
  • Migrate the plugin to the pubspec platforms manifest.
  • Bump the minimum Flutter version to 1.10.0.

6.0.6 #

  • Updated README instructions for Android.

6.0.5 #

  • Add import for UserNotifications on iOS.

6.0.4 #

  • Support the v2 Android embedding.

6.0.3 #

  • Fix bug where onIosSettingsRegistered wasn't streamed on iOS >= 10.

6.0.2 #

  • Fixed a build warning caused by availability check.

6.0.1 #

  • FirebaseMessaging.configure will throw an ArgumentError when onBackgroundMessage parameter is not a top-level or static function.

6.0.0 #

  • Use UNUserNotificationCenter to receive messages on iOS version >= 10.

  • Breaking Change For iOS versions >= 10, this will cause any other plugin that specifies a UNUserNotificationCenterDelegate to [UNUserNotificationCenter currentNotificationCenter] to stop receiving notifications. To have this plugin work with plugins that specify their own UNUserNotificationCenterDelegate, you can remove the line

    [UNUserNotificationCenter currentNotificationCenter].delegate = // plugin specified delegate
    

    and add this line to your iOS project AppDelegate.m

    if (@available(iOS 10.0, *)) {
      [UNUserNotificationCenter currentNotificationCenter].delegate = (id<UNUserNotificationCenterDelegate>) self;
    }
    

5.1.9 #

  • Fix strict compilation errors.

5.1.8 #

  • Updated README instructions for contributing for consistency with other Flutterfire plugins.

5.1.7 #

  • Remove AndroidX warning.

5.1.6 #

  • Fix warnings when compiling on Android.

5.1.5 #

  • Enable background message handling on Android.

5.1.4 #

  • Update documentation to reflect new repository location.
  • Update unit tests to call TestWidgetsFlutterBinding.ensureInitialized.

5.1.3 #

  • Update google-services Android gradle plugin to 4.3.0 in documentation and examples.

5.1.2 #

  • Updates to README and example with explanations of differences in data format.

5.1.1 #

  • Update README with more detailed integration instructions.

5.1.0 #

  • Changed the return type of subscribeToTopic and unsubscribeFromTopic to Future<void>.

5.0.6 #

  • Additional integration tests.

5.0.5 #

  • On Android, fix crash when calling deleteInstanceID with latest Flutter engine.

5.0.4 #

  • Automatically use version from pubspec.yaml when reporting usage to Firebase.

5.0.3 #

  • Update Dart code to conform to current Dart formatter.

5.0.2 #

  • Add missing template type parameter to invokeMethod calls.
  • Bump minimum Flutter version to 1.5.0.
  • Replace invokeMethod with invokeMapMethod wherever necessary.

5.0.1+1 #

  • Enable support for onMessage on iOS using shouldEstablishDirectChannel.

5.0.1 #

  • Fix error in the logs on startup if unable to retrieve token on startup on Android.

5.0.0 #

  • Update Android dependencies to latest.

4.0.0+4 #

  • Remove obsolete use_frameworks! instruction.

4.0.0+3 #

  • Update iOS configuration documentation.

4.0.0+2 #

  • Fix example app's floating action button that stopped working due to a breaking change.

4.0.0+1 #

  • Log messages about automatic configuration of the default app are now less confusing.

4.0.0 #

  • Breaking Change Update message structure for onMessage to match onLaunch and onResume

3.0.1 #

  • Log a more detailed warning at build time about the previous AndroidX migration.

3.0.0 #

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

    This was originally incorrectly pushed in the 2.2.0 update.

2.2.0+1 #

  • Revert the breaking 2.2.0 update. 2.2.0 was known to be breaking and should have incremented the major version number instead of the minor. This revert is in and of itself breaking for anyone that has already migrated however. Anyone who has already migrated their app to AndroidX should immediately update to 3.0.0 instead. That's the correctly versioned new push of 2.2.0.

2.2.0 #

  • BAD. This was a breaking change that was incorrectly published on a minor version upgrade, should never have happened. Reverted by 2.2.0+1.

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

2.1.0 #

  • Adding support for deleteInstanceID(), autoInitEnabled() and setAutoInitEnabled().

2.0.3 #

  • Removing local cache of getToken() in the dart part of the plugin. Now getToken() calls directly its counterparts in the iOS and Android implementations. This enables obtaining its value without calling configure() or having to wait for a new token refresh.

2.0.2 #

  • Use boolean values when checking for notification types on iOS.

2.0.1 #

  • Bump Android dependencies to latest.

2.0.0 #

  • Updated Android to send Remote Message's title and body to Dart.

1.0.5 #

  • Bumped test and mockito versions to pick up Dart 2 support.

1.0.4 #

  • Bump Android and Firebase dependency versions.

1.0.3 #

  • Updated iOS token hook from 'didRefreshRegistrationToken' to 'didReceiveRegistrationToken'

1.0.2 #

  • Updated Gradle tooling to match Android Studio 3.2.2.

1.0.1 #

  • Fix for Android where the onLaunch event is not triggered when the Activity is killed by the OS (or if the Don't keep activities toggle is enabled)

1.0.0 #

  • Bump to released version

0.2.5 #

  • Fixed Dart 2 type error.

0.2.4 #

  • Updated Google Play Services dependencies to version 15.0.0.

0.2.3 #

  • Updated package channel name

0.2.2 #

  • Simplified podspec for Cocoapods 1.5.0, avoiding link issues in app archives.

0.2.1 #

  • Fixed Dart 2 type errors.

0.2.0 #

  • Breaking change. Set SDK constraints to match the Flutter beta release.

0.1.4 #

  • Fixed Dart 2 type error in example project.

0.1.3 #

  • Enabled use in Swift projects.

0.2.2 #

  • Fix for APNS not being correctly registered on iOS when reinstalling application.

0.1.1 #

  • Simplified and upgraded Android project template to Android SDK 27.
  • Updated package description.

0.1.0 #

  • Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.
  • Relaxed GMS dependency to [11.4.0,12.0[

0.0.8 #

  • Added FLT prefix to iOS types
  • Change GMS dependency to 11.4.+

0.0.7 #

In FirebaseMessagingPlugin.m:

  • moved logic from 'tokenRefreshNotification' to 'didRefreshRegistrationToken'
  • removed 'tokenRefreshNotification' as well as observer registration
  • removed 'connectToFcm' method and related calls
  • removed unnecessary FIRMessaging disconnect

0.0.6 #

  • Change GMS dependency to 11.+

0.0.5+2 #

  • Fixed README example for "click_action"

0.0.5+1 #

  • Aligned author name with rest of repo.

0.0.5 #

  • Updated to Firebase SDK to always use latest patch version for 11.0.x builds

0.0.4 #

  • Updated to Firebase SDK Version 11.0.1

0.0.3 #

  • Updated README.md
  • Bumped buildToolsVersion to 25.0.3

0.0.2+2 #

  • Updated README.md

0.0.2+1 #

0.0.2 #

  • Updated to latest plugin API

0.0.2.2 #

  • Downgraded gradle dependency for example app to make flutter run happy

0.0.1+1 #

  • Updated README with installation instructions
  • Added CHANGELOG

0.0.1 #

  • Initial Release
629
likes
100
pub points
99%
popularity

Publisher

firebase.google.com

Flutter plugin for Firebase Cloud Messaging, a cross-platform messaging solution that lets you reliably deliver messages on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_core, flutter, meta, platform

More

Packages that depend on firebase_messaging