firebase_admin_interop 2.1.0
firebase_admin_interop: ^2.1.0 copied to clipboard

Firebase Admin SDK for Dart written as a wrapper around official Node.js SDK.

20
likes
90/ 130
pub points
77%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 570 out of 926 API elements (61.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:firebase_admin_interop/firebase_admin_interop.dart that imports:
  • package:firebase_admin_interop/src/messaging.dart that imports:
  • package:firebase_admin_interop/src/bindings.dart that imports:
  • package:firebase_admin_interop/src/firestore_bindings.dart that imports:
  • package:node_interop/stream.dart that imports:
  • package:node_interop/node.dart that imports:
  • package:node_interop/timers.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.1+10.6.30.6.3
meta^1.1.81.7.01.7.0
node_interop^1.0.31.2.12.1.0
quiver_hashcode^2.0.02.0.03.0.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.3` on node_interop does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions node_interop to update the constraint.

The constraint `^2.0.0` on quiver_hashcode does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver_hashcode to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

20
likes
90
pub points
77%
popularity

Firebase Admin SDK for Dart written as a wrapper around official Node.js SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

js, meta, node_interop, quiver_hashcode

More

Packages that depend on firebase_admin_interop