filex 0.3.0
filex: ^0.3.0 copied to clipboard

A configurable file explorer widget for Flutter. Trailing and leading widgets are configurable.

4
likes
80 / 130
pub points
79 %
popularity

We analyzed this package on May 4, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 50 out of 55 API elements (90.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:filex/filex.dart that imports:
  • package:filex/src/filex.dart that imports:
  • package:open_file/open_file.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/bloc.dart:63:15

   ╷
63 │               FlatButton(
   │               ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc.dart

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/src/bloc.dart:69:15

   ╷
69 │               FlatButton(
   │               ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bloc.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
extra_pedantic^1.2.01.3.01.3.0
filesize^1.0.41.0.41.0.4
flutterflutter0.0.00.0.0
flutter_slidable^0.5.70.5.70.6.0
open_file^3.0.33.2.03.2.0
path^1.7.01.8.01.8.0
path_provider^1.6.241.6.282.0.1
pedantic^1.9.21.11.01.11.0
permission^0.1.70.1.70.1.7
rxdart^0.25.00.25.00.26.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.0.01.0.0
file-6.1.06.1.0
meta-1.3.01.3.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.5.7` on flutter_slidable does not support the stable version `0.6.0`, that was published 22 days ago.

When flutter_slidable is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_slidable to update the constraint.

The constraint `^1.6.24` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

4
likes
80
pub points
79%
popularity

A configurable file explorer widget for Flutter. Trailing and leading widgets are configurable.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ansterj@gmail.com

License

MIT (LICENSE)

Dependencies

extra_pedantic, filesize, flutter, flutter_slidable, open_file, path, path_provider, pedantic, permission, rxdart

More

Packages that depend on filex