ffmpeg_kit_flutter_full 6.0.3 copy "ffmpeg_kit_flutter_full: ^6.0.3" to clipboard
ffmpeg_kit_flutter_full: ^6.0.3 copied to clipboard

unlisted

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

4
likes
130/ 160
pub points
91%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/arthenica/ffmpeg-kit/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: ffmpeg_kit_flutter_full,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: ffmpeg_kit_flutter_full.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-3.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

244 out of 337 API elements (72.4 %) have documentation comments.

Some symbols that are missing documentation: abstract_session, arch_detect, chapter, chapter.Chapter.keyEnd, chapter.Chapter.keyEndTime.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ffmpeg_kit_flutter_full/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:ffmpeg_kit_flutter_full/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:ffmpeg_kit_flutter_full/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Use 'isNotEmpty' instead of 'length' to test whether the collection is empty.

lib/ffmpeg_session.dart:113:13

    ╷
113 │         if (statistics.length > 0) {
    │             ^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ffmpeg_session.dart

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/media_information_json_parser.dart:39:35

   ╷
39 │         if (properties == null || properties.length == 0) {
   │                                   ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/media_information_json_parser.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffmpeg_kit_flutter_platform_interface ^0.2.1 0.2.1 0.2.1
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
130
pub points
91%
popularity

Publisher

verified publisherarthenica.com

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LGPL-3.0 (LICENSE)

Dependencies

ffmpeg_kit_flutter_platform_interface, flutter

More

Packages that depend on ffmpeg_kit_flutter_full