ffmpeg_kit_flutter_full 6.0.3 copy "ffmpeg_kit_flutter_full: ^6.0.3" to clipboard
ffmpeg_kit_flutter_full: ^6.0.3 copied to clipboard

unlisted

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add ffmpeg_kit_flutter_full

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  ffmpeg_kit_flutter_full: ^6.0.3

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:ffmpeg_kit_flutter_full/abstract_session.dart';
import 'package:ffmpeg_kit_flutter_full/arch_detect.dart';
import 'package:ffmpeg_kit_flutter_full/chapter.dart';
import 'package:ffmpeg_kit_flutter_full/ffmpeg_kit.dart';
import 'package:ffmpeg_kit_flutter_full/ffmpeg_kit_config.dart';
import 'package:ffmpeg_kit_flutter_full/ffmpeg_session.dart';
import 'package:ffmpeg_kit_flutter_full/ffmpeg_session_complete_callback.dart';
import 'package:ffmpeg_kit_flutter_full/ffprobe_kit.dart';
import 'package:ffmpeg_kit_flutter_full/ffprobe_session.dart';
import 'package:ffmpeg_kit_flutter_full/ffprobe_session_complete_callback.dart';
import 'package:ffmpeg_kit_flutter_full/level.dart';
import 'package:ffmpeg_kit_flutter_full/log.dart';
import 'package:ffmpeg_kit_flutter_full/log_callback.dart';
import 'package:ffmpeg_kit_flutter_full/log_redirection_strategy.dart';
import 'package:ffmpeg_kit_flutter_full/media_information.dart';
import 'package:ffmpeg_kit_flutter_full/media_information_json_parser.dart';
import 'package:ffmpeg_kit_flutter_full/media_information_session.dart';
import 'package:ffmpeg_kit_flutter_full/media_information_session_complete_callback.dart';
import 'package:ffmpeg_kit_flutter_full/packages.dart';
import 'package:ffmpeg_kit_flutter_full/return_code.dart';
import 'package:ffmpeg_kit_flutter_full/session.dart';
import 'package:ffmpeg_kit_flutter_full/session_state.dart';
import 'package:ffmpeg_kit_flutter_full/signal.dart';
import 'package:ffmpeg_kit_flutter_full/statistics.dart';
import 'package:ffmpeg_kit_flutter_full/statistics_callback.dart';
import 'package:ffmpeg_kit_flutter_full/stream_information.dart';
4
likes
130
pub points
91%
popularity

Publisher

verified publisherarthenica.com

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LGPL-3.0 (LICENSE)

Dependencies

ffmpeg_kit_flutter_platform_interface, flutter

More

Packages that depend on ffmpeg_kit_flutter_full