femtolytics 1.0.0
femtolytics: ^1.0.0

Flutter Android iOS

A flutter client to femtolytics, a tiny app analytics open source framework.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Nov 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 21 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:femtolytics/femtolytics.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^0.4.2+40.4.2+101.0.0
flutter_user_agent^1.2.21.2.21.2.2
http^0.12.0+20.12.20.12.2
logging^0.11.3+20.11.40.11.4
package_info^0.4.0+130.4.3+20.4.3+2
path^1.6.41.7.01.8.0-nullsafety.3
path_provider^1.6.111.6.241.6.24
sqflite^1.3.0+11.3.2+11.3.2+1
uuid^2.0.42.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
device_info_platform_interface-1.0.11.0.1
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
source_span-1.7.01.8.0-nullsafety.4
sqflite_common-1.0.2+11.0.2+1
string_scanner-1.0.51.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.2+4` on device_info does not support the latest published version `1.0.0`

pubspec.yaml:14:16

   ╷
14 │   device_info: ^0.4.2+4
   │                ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

A flutter client to femtolytics, a tiny app analytics open source framework.

Homepage

Documentation

API reference

Uploader

poitch@gmail.com

License

MIT (LICENSE)

Dependencies

device_info, flutter, flutter_user_agent, http, logging, package_info, path, path_provider, sqflite, uuid

More

Packages that depend on femtolytics